Idealo monitoring blocked by anti-bot mechanism

Incident Report for Omnia Retail

Resolved

Good news! This incident has been resolved. Our monitoring shows that performance has remained stable throughout the week and offers continue to be refreshed in real time.

If you have any questions, feel free to call us at +31 (0)85 047 9241 or email customerservice@omniaretail.com. We're here to help.
Posted Jul 17, 2026 - 11:46 CEST

Monitoring

We've implemented a fix and, since this weekend, we've been able to collect fresh offer data from Idealo.

We'll keep monitoring the results for the next week to ensure this fix continues to perform reliably while maintaining data quality and stability. We're simultaneously developing fallback solutions for scraping Idealo to prevent future outages.

As always, if you have any questions, feel free to give us a call at +31 (0)85 047 9241 or email us at customerservice@omniaretail.com.
Posted Jul 13, 2026 - 09:44 CEST

Investigating

Our capacity to monitor Idealo is currently being blocked by bot-detection systems. As a result, we are unable to retrieve fresh offers from Idealo domains since this morning (approx. 5AM CET). To ensure data and service continuity, we are using cached offer data where necessary.

Our team is actively working on bypassing the new anti-bot mechanisms and we'll keep you updated on our progress.

As always, if you have any questions, feel free to give us a call at +31 (0)85 047 9241 or email us at customerservice@omniaretail.com.
Posted Jul 10, 2026 - 13:48 CEST
This incident affected: Market Data.